web/ts-0.5.4.ebuild
changeset 213 d18e1091fae9
parent 212 0bd944d8babf
equal deleted inserted replaced
212:0bd944d8babf 213:d18e1091fae9
     1 # Copyright 1999-2007 Gentoo Foundation
     1 # Copyright 1999-2008 Gentoo Foundation
     2 # Distributed under the terms of the GNU General Public License v2
     2 # Distributed under the terms of the GNU General Public License v2
     3 # $Header: $
     3 # $Header: $
     4 
     4 
     5 inherit eutils
     5 inherit toolchain-funcs
     6 
     6 
     7 DESCRIPTION="A comfortable way of running batch jobs"
     7 DESCRIPTION="TaskSpooler is a comfortable way of running batch jobs"
     8 HOMEPAGE="http://vicerveza.homeunix.net/~viric/soft/ts/"
     8 HOMEPAGE="http://vicerveza.homeunix.net/~viric/soft/ts/"
     9 SRC_URI="http://vicerveza.homeunix.net/~viric/soft/ts/${P}.tar.gz"
     9 SRC_URI="http://vicerveza.homeunix.net/~viric/soft/ts/${P}.tar.gz"
    10 
    10 LICENSE="GPL-2"
    11 LICENSE="GPL"
       
    12 SLOT="0"
    11 SLOT="0"
    13 KEYWORDS="~x86"
    12 KEYWORDS="~amd64 ~x86"
    14 IUSE=""
    13 IUSE=""
    15 
    14 
    16 DEPEND=""
    15 DEPEND=""
    17 RDEPEND=""
    16 RDEPEND=""
    18 
    17 
       
    18 src_unpack() {
       
    19 	unpack ${A}
       
    20 	cd "${S}"
       
    21 
       
    22 	sed -i \
       
    23 		-e 's|CFLAGS=|CFLAGS+=|' \
       
    24 		-e 's|-g -O0||' \
       
    25 		Makefile || die "sed failed"
       
    26 }
       
    27 
    19 src_compile() {
    28 src_compile() {
    20 	emake || die "emake failed"
    29 	emake CC=$(tc-getCC) || die "emake failed"
    21 }
    30 }
    22 
    31 
    23 src_install() {
    32 src_install() {
    24 	exeinto /usr/bin
    33 	exeinto /usr/bin
    25 	doexe ts
    34 	doexe ts
    26 	doman ts.1
    35 	doman ts.1
    27 	dodoc Changelog OBJECTIVES PORTABILITY PROTOCOL README TRICKS
    36 	dodoc Changelog OBJECTIVES PORTABILITY PROTOCOL README TRICKS
    28 }
    37 }
       
    38 
       
    39 src_test() {
       
    40 	PATH="${D}/usr/bin:${PATH}" ./testbench.sh || die "tests failed"
       
    41 }